Esiste un modo per installare il modulo TWAIN in Python 3

voti
1

Voglio installare il modulo Python TWAIN in Python 3. Ma nella documentazione si dice:

Sono supportate le versioni di Python 2.1 tramite 2.5.

Posso convertire usando 2to3?

È pubblicato 12/01/2016 alle 13:06
dall'utente
In altre lingue...                            


1 risposte

voti
0

Utilizzare passato modulo che fornisce un pacchetto di traduzione sperimentale per aiutare con l'importazione e utilizzando vecchi moduli Python 2 in un ambiente Python 3.

Quindi installare il pacchetto con pip

pip3 install twain --no-compile   # to ignore SyntaxErrors

E utilizzare il codice seguente per importare i due nel python3codice:

from past import autotranslate
autotranslate(['twain'])

import twain


# use twain ....... 
Risposto il 12/01/2016 a 13:13
fonte dall'utente

Cookies help us deliver our services. By using our services, you agree to our use of cookies. Learn more