Ricezione di un errore durante il tentativo di eseguire il comando di migrazione aggiungere nella console di gestione dei pacchetti

voti
32

Ho bisogno di un altro paio di occhi a guardare a questo. Il codice seguente viene eseguito in studio visivo e quando è inattivo barra laterale verde indica la sintassi è corretta.

Tuttavia quando ho eseguito una migrazione aggiuntivo nella console package manager risponde con il seguente errore.

Oggetto non valido passato a, ':' o '}' attesi (817).

Sembra prendere problema con la mia implementazione di dipendenza, ma non riesco a trovare qualsiasi istanza di una staffa mancante o virgola.

Se si può trovare sarò lieto di fornire la risposta con un voto alto. Grazie!

{
  buildOptions: {
    emitEntryPoint: true,
    preserveCompilationContext: true
  },
  dependencies: {
    Microsoft.NETCore.App: {
      version: 1.0.1,
      type: platform
    },
    Microsoft.AspNetCore.Diagnostics: 1.0.0,
    Microsoft.Extensions.Configuration.FileExtensions: 1.0.0,
    Microsoft.AspNetCore.Server.IISIntegration: 1.0.0,
    Microsoft.AspNetCore.Server.Kestrel: 1.0.1,
    Microsoft.Extensions.Logging.Console: 1.0.0,
    Microsoft.Extensions.Configuration.Json: 1.0.0,
    Microsoft.AspNetCore.StaticFiles: 1.0.0,
    Microsoft.AspNetCore.Mvc: 1.0.0,
    Microsoft.EntityFrameworkCore.SqlServer: 1.1.0,
    Microsoft.EntityFrameworkCore.Tools: 1.1.0-preview4-final,
    Microsoft.AspNetCore.Identity: 1.0.0 //New package required for added functionality
  },
  frameworks: {
    netcoreapp1.0: {
      imports: [
        dotnet5.6,
        portable-net45+win8
      ]
    }
  },
  publishOptions: {
    include: [
      wwwroot,
      web.config
    ]
  },
  runtimeOptions: {
    configProperties: {
      System.GC.Server: true
    }
  },
  scripts: {
    postpublish: [ dotnet publish-iis --publish-folder %publish:OutputPath% --framework %publish:FullTargetFramework% ]
  },
  tools: {
    Microsoft.AspNetCore.Server.IISIntegration.Tools: 1.0.0-preview2-final,
    Microsoft.EntityFrameworkCore.Tools: 1.1.0-preview4-final
  }
}
È pubblicato 22/11/2016 alle 17:49
dall'utente
In altre lingue...                            


1 risposte

voti
6

L'unico problema che rilevo sul JSON è il commento che avete qui

//New package required for added functionality

I commenti non sono validi su una struttura JSON quindi probabilmente l'errore è legata a quella.

Risposto il 22/11/2016 a 17:54
fonte dall'utente

Cookies help us deliver our services. By using our services, you agree to our use of cookies. Learn more